// Основная форма Рабочего места продажи..
  
  Процедура ПриОткрытии()
	//
	// -- Skip ---
	//
	ЭлементыФормы.ФлагВхПеремещения.Видимость = Ложь; //картинка в виде "Ромашки"
	ЭлементыФормы.ФлагВхПеремещения.Доступность = Ложь;
	ПодключитьОбработчикОжидания("ПроверкаВходящихПеремещений",30);

  КонецПроцедуры // ПриОткрытии()
	
  Процедура ПроверкаВходящихПеремещений()
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Отправитель", ЭтотОбъект.Склад);

Запрос.Текст = "
|ВЫБРАТЬ
|	ПеремещениеТоваров.Ссылка
|ИЗ
|	Документ.ПеремещениеТоваров КАК ПеремещениеТоваров
|ГДЕ
|	ПеремещениеТоваров.СкладОтправитель = &Отправитель
|	И ПеремещениеТоваров.Проведен = ЛОЖЬ
|	И ПеремещениеТоваров.ПометкаУдаления = ЛОЖЬ
|";
Рез = Запрос.Выполнить().Выбрать();
Если Рез.Количество()=0 Тогда //нет для склада непроведенных ПТ
	ЭлементыФормы.ФлагВхПеремещения.Видимость = Ложь;
	ЭлементыФормы.ФлагВхПеремещения.Доступность = Ложь;
Иначе 
	ЭлементыФормы.ФлагВхПеремещения.Видимость = Истина;
	ЭлементыФормы.ФлагВхПеремещения.Доступность = Истина;
КонецЕсли;
КонецПроцедуры